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 مقدمه ی مترجم

داي ن برنامه اغلب در ابتای بینید. یعني یک دفترچه ي تلفن و قرار ملاقات. در واقعمين مقاله یک برنامه ي به ظاهر ساده ي بانک اطلاعاتي ایدر

ي داشته لاعاتبانک اط نویسيبرنامهیافته به ن مؤلف( یک نگاه ساختای واقع رن برنامه )دایشود. لیکنميیادگیري بانک اطلاعاتي در ویندوز نوشته 

آن است که برنامه به صورت ماژولار  نیازمند MySQLو  MS SQLنوع بانک اطلاعاتي اکسس،  8شارپ و پشتیباني از است. استفاده از زبان سي

 ي متنوع دیگر از جمله استفاده از مودمهادهای گیري و بازیابي وو پشتیبان XMLطراحي شده باشد. انواع کنترل خطا و استفاده از چاپگر و فایل  

ن فلفل نبی»زمان با آن و هم« جا داريرند تو یکآنچه خوبان همه دا»المثل ن برنامه نمونه ي کامل ضربایه براي تماس تلفني باعث شده است ک

 باشد.« چه ریزه

طرف از آن اند ویاد گرفته اویژوال ر نویسيبرنامهو مقدمات  هادانند و کنترلميرا  نویسيبرنامهاین برنامه براي افرادي است که به طور جداگانه زبان 

ن برنامه ای تر گام بردارند. با الگو گرفتن ازايحرفه نویسيبرنامهخواهند به سمت مينگاهي به حداقل یک نوع بانک اطلاعاتي داشته اند. حالا هم نیم

کامپیوتر به آن ي هاي کوچک که دانشجویان یا کارآموزان رشتههاطراحي و تولید کنید چرا که اغلب در مثال اتان ري تجاريهاتوانید برنامهمي

 ه به هر بدبختي و گرفتن دو نمره ي ناقابل مطرح است و بس.مصرف جواب دادن برنا ،پردازندمي

ي پایین تر استفاده نمایند، به همین هاو خیلي از کاربران ممکن است هنوز از نگارشرا نصب کرده ام  0212در ضمن از آنجا که من ویژوال استودیو 

ري نکردم تا اصل آن براي همه قابل استفاده باشد. در عین حال همین تصمیم باعث شده که خواننده ي مقاله اندکي با دلیل سورس کد را دستکا

ا آشن  -ب واجبات استجدنیا بوده و یادگیري آن براي به ویژه کامپیوتري جماعت از او ميکه زبان عل -ي انگلیسي هامعادل فارسي شده ي واژه

  شود.

وژه ي شان یک پرنده مطرح شده است که هر کدامیآ ي برنامه درهایي از طرف مؤلف اصلي برنامه به عنوان قابلیتهادهای برنامه نیزدر بخش پایاني 

یک قدم  هادهای را بالا بزنید. به نظر من همین مطرح شدن آن هاخواهید یاد بگیرید منتظر مؤلف اصلي مقاله نباشید و آستینميمستقل است. اگر 

 تان اضافه نمایید.و به جلو است و شما باید به عنوان کسي که در حال یادگیري است خودتان دست به کار شوید و امکانات جدید را به برنامهر
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توانید اطلاعات را در سه نوع بانک ميقرارها را نیز خواهد داشت. شما  ثبتدهد و امکان ميرا  هاگیري از دادهاین برنامه به شما امکان پشتیبان

 ذخیره نمایید. MySQLو  MS SQLاطلاعاتي مختلف شامل اکسس میکروسافت، 

 مقدمه

ن ای گردد.ميیا بالاتر اجرا  0توسعه داده شده است و در دات نت نگارش  #Cاست که با استفاده از  پر فایدهاین برنامه ساده و در عین حال بسیار 

نماید و علاوه بر آن رویدادها و قرارها را ذخیره کرده، نمایش ميمیل، شماره تلفن و ... ذخیره ایي شما را مانند نام، نشاني،هاتماسبرنامه اطلاعات 

 ن برنامه امکان یادآوري رویدادها در زمان تعیین شده توسط کاربر خواهد بود.اینده ایآ يهادهد. در نگارشمي

با  اهدهد. امکان پشتیبان گیري از دادهميطراحي شده است و اطلاعات مربوط به هر کاربر را براي خود او نمایش ربري این برنامه به صورت چندکا

 گیري با الگوين پشتیبانای ن برنامه وجود دارد.ای توسط کلمه ي رمز هم در هاو همچنین به صورت رمزنگاري شده و محافظت از آن XMLفورمت 

گیرد. شماتیک مورد بحث در واقع از مجموعه دستورهایي تشکیل شده است که کاربر مي، انجام بخواهدآن چه کاربر یا خودش شماتیک پیش فرض 

و  MS SQLمت اکسس میکروسافت، ررا در سه فو هاتواند دادهمين برنامه ای گیري شوند.یي پشتیبانهاچه داده کندميتعیین  هاتوسط آن

MySQL  .ذخیره نماید 

 

 تنظيمات بانک اطلاعاتي

 MS SQLتواند اکسس یا ميلازم دارد. بانک اطلاعاتي مذکور  هااین برنامه یک اتصال بانک اطلاعاتي براي ذخیره سازي اطلاعات مربوط به تماس

 اطلاعاتي را تنظیم کند. شود که اتصال بانکميگردد پیغام زیر براي کاربر نمایش داده ميمه براي نخستین بار اجرا اباشد. زماني که برن

 

 
 

 را کلیک کنید تا پنجره ي زیر نمایش داده شود: Yesبراي تنظیم اتصال به بانک اطلاعاتي دکمه ي 

 

 
توانید تعیین کنید که برنامه با هر بار بالا آمدن ویندوز به طور خودکار ميدر ضمن تان را انتخاب نمایید. نوع بانک اطلاعاتي مورد استفاده ن فرمایدر

شده توسط شما نمایش داده ن مرحله تنظیمات اتصال بانک اطلاعاتي متناسب با نوع بانک انتخابایرا بزنید. پس از Saveدکمه ي اجرا شود. 

 شود.مي
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 SQLتظيمات بانک اطلاعاتي 

 
 

را انتخاب  SQL Server Authenticationیا  Windows Authenticationو همچنین روش شناسایي کاربر  SQLن فرم نام سرور ایدر

با نام  SQL Serverکنید. اگر روش دوم را انتخاب کنید نام کاربر و گذرواژه را نیز باید وارد نمایید و اگر روش نخست باشد بسته به نوع نصب مي

ن بخش درست باشد و اتصال به بانک ایاگر اطلاعات ورودي در کاربري و گذرواژه کاربر فعلي ویندوز به سرور بانک اطلاعاتي متصل خواهید شد.

را  Saveي داخل سرور نمایش داده خواهد شد. دیتابیس مورد نظر را از فهرست انتخاب کرده، دکمه ي هااطلاعاتي برقرار گردد فهرست دیتابیس

 بزنید.

 

 تنظيمات بانک اطلاعاتي اكسس

 

 را بزنید. Saveبانک اطلاعاتي اکسس را انتخاب کنید و اگر کلمه ي رمز دارد آن را هم وارد کرده، دکمه ي  mdbن پنجره فایل ایدر
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 MySQLتنظيمات بانک اطلاعاتي 

 

که برنامه در حال اجرا است نصب شده است مي)اگر روي همین سیستن فرم نام کامپیوتري را که سرور بانک اطلاعاتي در آن نصب شده است، ایدر

نام کاربري و گذرواژه )در صورت لزوم( را وارد نمایید سپس دیتابیس مورد نظر را از فهرست انتخاب  را وارد نمایید( 127.0.0.1پي يآ آدرس

 Save ینان از درست بودن تنظیمات دکمهپس از اطمنمایش داده نشوند یعني برنامه به بانک اطلاعاتي متصل نشده است.  هااگر دیتابیس ید.نمای

 را بزنید. پس از مرحله ي اعمال تنظیمات بانک اطلاعاتي برنامه را مجدد اجرا نمایید تا به بانک متصل شود. 

کن ای( به صورت مینیمایز خواهید دید. رويNotification Areaکن ساعت ویندوز )ناحیه ي یادآوري یا همان یآ کنارکن برنامه را یآ پس از اجرا،

 انتخاب نمایید. ار Contactsیا  Loginکلیک کنید و گزینه ي 

 نخستين ورود به برنامه

 

در نخستین اجراي برنامه وجود نداشته باشد، برنامه از شما خواهد خواست که ن برنامه نیاز به نام کاربر و گذرواژه داشته باشد و اطلاعات آن ایاگر

را بزنید. پس از آن پنجره ي مدیریت کاربران مطابق شکل زیر نمایش داده خواه   Yesجاد کاربر جدید دکمه ي ایبرايجاد نمایید. ایکاربر جدید

 شد.
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و  (Administrator)شود. دو نوع سطح دسترسي براي کاربر داریم، کاربر مدیر مين فرم فهرست کاربران در یک کنترل دیتاگرید نشان داده ایدر

 (Limited User)کاربر محدود 

Administrator: یرایش و حذف کاربران اشاره جاد، وای به توانميسطح دسترسي، اختیار کامل در برنامه دارد که از جمله ي آن ن ایکاربر با

اگر چه امکان ویرایش و حذف رکوردهاي دیگران  دید،د و رکوردهاي مربوط به هر کدام را ارواژه ي کاربران دیگر را تغییر دگذ توانميدر ضمن نمود. 

 را ندارد. حداقل یک کاربر با سطح دسترسي مدیر باید در برنامه تعریف شود.

Limited User: گذرواژه شان را تغییر دهند. رکوردهایيتوانند ميتوانند به بخش مدیریت کاربران دسترسي پیدا کنند لیکن ميکاربران ن این 

د رکوردهاي توانمين نوع کاربر نایجاد شود توسط کاربر مدیر قابل مشاهده است ولي قابل ویرایش و حذف نیست. در ضمناین نوع کاربرای که توسط

 تعریف شده باشند. (Shared Contact)ن که آن رکوردها به صورت اشتراکي ایتوسط دیگر کاربران را ببیند مگر اضافه شده

 كاربر جدید

 کلیک کنید تا فرم تعریف کاربر جدید مطابق شکل زیر نمایش داده شود: Addروي نخستین دکمه یعني 

 

به کاربر  Allow User to Loginبا فعال کردن گزینه ي ، نوع کاربر یا همان سطح دسترسي و گذرواژه ي آن را وارد نمایید. در فرم بالا نام کاربر

خورد که بخواهید بدون حذف یک کاربر از ورود آن به برنامه پیشگیري کنید. به مين قابلیت در جایي به درد ای دهید که وارد برنامه شود.ميامکان 

 شود از جملهميشود که در آن علاوه بر مشخصات اصلي کاربر اطلاعات دیگري نمایش داده ميهنگام ویرایش یک کاربر، همین فرم نمایش داده 

 ن که آخرین بار چه زماني وارد برنامه شده است.ایایش بر روي آن انجام شده است وجاد شده است، چه زماني آخرین ویراین که کاربر چه زمانيای

 را بزنید تا کاربر جدید به سیستم اضافه شود. Add Userدکمه ي 

 ند. را بزنید تا تغییرات ذخیره شو Closeتوانید اضافه نمایید. دکمه ي چهارم یا همان ميبه همین ترتیب هر تعداد کاربر که خواستید 
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 سپس فرم ورود به برنامه نمایش داده خواهد شد:

 

 را مشاهده، اضافه و ویرایش نمایید. هان فرم نام کاربر و گذرواژه را وارد نمایید تا بتوانید اطلاعات تماسای در

 هافرم تماس

 

ي یک کاربر دلخواه، نام کاربر مورد نظر را از پانل هارکورد دهد. براي مشاهدهميفرم بالا رکوردهایي را که توسط کاربر فعلي افزوده شده است نشان 

ي هاي خودش و تماسهاتواند تماسميکاربر عادي صرفا کلیک کنید. در پانل سمت چپ دابل categoryسمت چپ انتخاب کنید و روي دکمه ي 

 دیگر کاربران را که به صورت اشتراکي تعریف شده اند، ببیند. 

که در  یيهارکوردو دیگري دسته بندي نشده. همه ي  (Categorized)بندي شده شوند. یکي دستهميبه دو گروه تقسیم  ي ذخیره شدههاتماس

شوند به طور پیش فرض ميیي که تازه افزوده هاگیرند. به علاوه رکوردميقرار  Uncategorizedبندي نشده اند در شاخه ي هیچ موضوعي رده
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 <- Newکافي است رده ي مورد نظرتان را انتخاب و روي آن راست کلیک کنید و گزینه ي  هابندي تماسبراي دستهگیرند. مين گروه قرار ایدر

Contact  .را انتخاب نمایید 

زینه گ بندي شده را از پانل سمت چپ استفاده کنید و روي آن راست کلیک کنید. سپسن کار ابتدا یک گروه دستهایبراي: ی جدیددسته افزودن 

New -> Category  .ذیرد.پميشود و شما باید نام آن را وارد نمایید چرا که نام پیش فرض را برنامه نميجدید به فهرست اضافه  یک ردهرا بزنید 

 جاد کنید وجود ندارد.ای نامي همهان که در یک گروه، ردهای تعریف شوند. امکان (توانند به طور نامحدود و تو در تو )زیر مجموعهمي هان ردهای

( را بزنید و تمام اطلاعات جزئیات مربوط به تماس را که Ctrl + N) یا میانبر  Options -> New Contactگزینه ي : افزدون تماس جدید

 Addressن بخش به برنامه ي ایجدا شده اند مانند نام، شماره تماس خانه، محل کار و ... را وارد نمایید. (tab control)ي مختلف هادر برگه

Book  ویندوز خیلي شبیه است. جزئیات مورد نظر مربوط به رکورد را وارد و با زدن دکمه يSave  تغییرات را ذخیره نمایید. فرم بالا تمام

 را بفشارید.  F5کلید را بزنید یا  View -> Refreshدهد. اگر چنین نبود گزینه ميکنید همان لحظه نشان ميیي را که شما وارد هاتماس

را  Ctrl+Oمیانبر کلید را بزنید. )یا  Options -> Edit Contactرکورد مورد نظرتان براي ویرایش را انتخاب کرده، گزینه ي : ویرایش تماس

شود که مشخصات تماس انتخاب شده در آن قرار دارد. موارد دلخواه تان را ویرایش کنید ميفشار دهید( همان فرم افزودن تماس جدید نمایش داده 

 را براي به روز رساني رکورد بزنید. Saveو دکمه 

ا ر Deleteرا کلیک کنید. )یا کلید میانبر  Options -> Delete Contactابتدا تماس مورد نظرتان را انتخاب کرده، گزینه ي : حذف تماس

 مورد نظر تان را انتخاب کنید و نتیجه را ببینید. شود. گزینهميحذف نشان داده فشار دهید( یک پیغام تأییدیه 

 را کلیک کنید تا فرم زیر نمایش داده شود: Options -> Find Peopleبراي جستجوي یک تماس گزینه ي : جستجو برای تماس

 

هست که اگر آن را  اين فرم گزینهای را بزنید. در پایین Find Nowدر فرم بالا یک یا چند فیلد از رکورد مورد نظر تان را وارد کرده، دکمه ي 

 شود.ميي پر شده ي فرم جستجو با آن منطبق باشد، نمایش داده هافعال کنید هر رکوردي که حداقل یکي از فیلد

 به بخش اختصاصي پشتیبان گیري مراجعه نمایید. :هاپشتيبان گيری از داده

جزئیات  Add Reminderرا کلیک کنید. در فرم  Options -> Reminder -> Add Eventبراي افزودن یک یادآوري گزینه ي  :هایادآوری

 View -> Reminderر فعال کردن گزینه  لازم را وارد نمایید. یادآوري در فرم تماس مربوط به خودش نمایش داده خواهد شد. با انتخاب یا غی

 را نشان دهد یا نه. هاتوانید از برنامه بخواهید که یادآوريمي
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را انتخاب کنید و گذرواژه ي پیشین و جدید را  Tools -> Change Passwordبراي تغییر گذرواژه ي کاربر فعلي گزینه ي  تغيير گذرواژه:

را  Tool -> User Accountتایپ کنید. براي تغییر گذرواژه ي یک کاربر دیگر )اگر کاربر فعلي سطح دسترسي مدیر داشته باشد( گزینه ي 

 کلیک کنید و پس از انتخاب کاربر، گذرواژه ي وي را تغییر دهید.

 را کلیک کنید.  Tools -> Settingsمات برنامه گزینه ي براي تغییر تنظیتغيير تنظيمات: 

 ي تان را پشتیبان بگیرید. هاتوانید تمام یا بخضي از رکورد )تماس(ميشما  :هاپشتيبان گيری از تماس

 را کلیک نمایید تا فرم پشتیبان گیري مطابق شکل زیر نمایش داده شود: Options -> Transfer Dataن کار گزینه ي ایبراي

 

 کنیم انتخاب نمایید.مين فرم جزئیات مربوط به پشتیبان گیري را مطابق آن چه در زیر بیان ایدر

ن دکمه کلیک ایفعال شود. روي Save Asرا انتخاب نمایید تا دکمه ي  Export Dataجاد یک پشتیبان جدید، گزینه ي ایبراي: گيریپشتيبان

)محافظت و رمزنگاري شده(  COB Backupقابل مشاهده هستند( یا  ها)رکورد XMLي هاکنید و نوع )فورمت( فایل پشتیبان را از بین حالت

بان تماس باید به نسخه پشتیي هاي مربوط به رکوردها( را انتخاب کنید که تعیین کند کدام فیلدیا همان پروفایل Schemaسپس طرح )برگزینید. 

 افزوده شود. براي اطلاعات بیشتر در مورد طرح به بخش ویرایش طرح در همین مقاله مراجعه نمایید.
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ي مربوط به نام کاربري و گذرواژه فعال خواهند شد. هاگزینهیا همان رمز نگاري شده تهیه کنید،  COBاگر تصمیم دارید که یک پشتیبان از نوع 

خواهید به نسخه ي پشتیبان افزوده ميي مورد نظر تان را که هارا کلیک نمایید. سپس تماس Setنام کاربر و گذرواژه را تایپ کنید و دکمه ي 

 کلیک کنید.  Transferشوند، انتخاب نمایید و در نهایت روي دکمه ي 

فعال شود. دکمه را کلیک  Openرا انتخاب نمایید تا دکمه ي  Import Dataبراي بازیابي نسخه ي پشتیبان گزینه  شتيبان:بازیابي نسخه ی پ

را وارد و را انتخاب نمایید و فایل مورد نظر رمزنگاري شده باشد، نام کاربري و گذرواژه  COBکنید و نوع فایل پشتیبان را انتخاب نمایید. اگر فایل 

ي ذخیره شده در فایل پشتیبان در کنترل دیتاگرد نمایش هارا کلیک کنید. اگر نام کاربري و گذرواژه درست باشند، رکورد )تماس( Setدکمه ي 

 ي تان بازیابي شوند.هارا کلیک کنید تا داده Transferي مورد نظر تان را انتخاب و دکمه ي هاشوند. تماسميداده 

 بان گيریپشتي (schema)استفاده از طرح 

رح توانید طميي تان را بازیابي کنید. شما هاخواهید فیلدهاي خاصي از رکوردميخورند که شما ميزماني به درد  هاطرح )به عبارت دیگر پروفایل(

ست. جاد شده باشد، توسط شما قابل تغییر نیای جاد، ویرایش یا حذف نمایید. لیکن طرح پشتیبان گیري که توسط کاربران دیگرایمورد نظر تان را

 کنار نام طرح را کلیک کنید: Editبراي افزودن یا ویرایش طرح دکمه ي 

 

 شود.ميفرم بالا براي ویرایش طرح پشتیبان گیري استفاده 

انتخاب  Schema Nameرا از فهرست بازشو ي  <Create New Schema>جاد کنید گزینه ي ایخواهید طرح جدیدمياگر  افزودن طرح:

د توانیميیي است که هافهرست سمت چپ صفحه حاوي تمام فیلدفعال شود. سپش نام طرح را در جعبه متن آن وارد نمایید.  Saveنمایید تا دکمه 

 نیازي هادیگر بقیه ي دکمهفکر کنم را بزنید تا به فهرست سمت راست افزوده شود.  <-ي مورد نظر تان را انتخاب و دکمه ي هاانتخاب نمایید. فیلد
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طرح را ذخیره نمایید. حال در فرم  Saveد. در نهایت با کلیک روي دکمه ي ایي ویندوزي دیدههابه توضیح واضحات ندارند چون در اغلب برنامه

Backup Wizard توانید طرح جدید تان را از فهرست انتخاب نمایید.مي 

پس از اعمال تغییرات مورد نظرتان فعال شود.  Editتدا آن را از فهرست انتخاب نمایید تا دکمه ي براي ویرایش طرح ابویرایش طرح موجود: 

ي گرفته شده توسط آن دیگر قابل استفاده نخواهند بود. هاتوجه داشته باشید اگر یک طرح را ویرایش نمایید، پشتیبانرا بزنید.  Saveدکمه ي 

 افتد(مين اتفاق ایگیرد. )حتي اگر صرفا نام طرح را عوض کنیدمينیز مطابق طرح صورت  هاچون بازیابي داده

 را بزنید تا حذف شود. Removeطرح را از فهرست انتخاب و دکمه ي  حذف طرح:
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 عمليات متفرقه

 Action -> Shareن کار رکورد مورد نظر تان را انتخاب و روي آن راست کلیک کنید. گزینه ي ای : براياشتراک یک تماس با بقيه كاربران

Contact ن حال رکورد به اشتراک گذاشته شده توسط سایر کاربران قابل مشاهده خواهد بود.ای را بزنید. در 

 Actions -> Unshareست کلیک و گزینه ي بدین منظور روي تماس به اشتراک گذاشته شده راغير فعال كردن اشتراک یک تماس: 

Contact .را برگزینید 

را از منوي  Cutتماس )هاي( مورد نظر تان را از فهرست انتخاب نمایید. راست کلیک کنید و گزینه ي ی مختلف: هاانتقال یک ركورد بين دسته

 را از منو انتخاب نمایید. Pasteباز شده برگزینید. سپس به پانل سمت چپ بروید و روي دسته ي مورد نظر تان راست کلیک کنید و گزینه ي 

را از منوي راست  Actions -> Callبراي شماره گیري توسط مودم تان، نخست تماس مورد نظر را انتخاب و سپس گزینه ي ه گيری: رشما

که چند  - DLLن کار به کمک یک فایل ایي شخص مورد نظر را انتخاب کنید.هاشود که یکي از شمارهميلیک باز شده بزنید. یک فرم جدید باز ک

 (Ras.dll) شود.ميانجام  -ماه پیش به صورت رایگان از یک سایت دانلود کردم

 را کلیک نمایید تا فرم زیر نمایش داده شود: Options -> Print Contactsن کار فرمان ایبراي: هاچاپ تماس

 

تواند به صورت جدولي )افقي ميفرم چاپي  قالبرا از فهرست انتخاب و سپس طرح فرم چاپي را انتخاب کنید.  هان فرم نخست همه ي تماسایدر

طابق م هاسپس طرح مورد نظر را براي چاپ انتخاب کنید تا فیلد ي جدول باشند یا نباشند. هان که خطور دور خانهای ( یا عمودي باشد وtabularیا 

را بزنید تا صفحه ي چاپي به صورت  Saveیي از جدول که در طرح موجود است چاپ خواهند شد. دکمه ي هاآن انتخاب شوند. فقط ستون )فیلد(

 ان باز کنید و روي کاغذ چاپ نمایید.وب ذخیره شود. اکنون فایل ذخیره شده را با مرورگر ت
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 خلاصه ی نکات مهم عملکرد برنامه

  را انتخاب نمایید. MySQLو   MS SQLتوانید سه نوع بانک اطلاعاتي اکسس،ميشما به یک نوع بانک اطلاعاتي محدود نیستید و 

که توسط دیگر کاربران قابل دسترسي نیست. اگر کاربر سطح  کندمياز رکوردها را ذخیره  اياین برنامه براي هر کاربر تعریف شده، فهرست جداگانه

 ندارد. هاي دیگران را ببیند ولي امکان ویرایش و حذف آنهاتواند رکوردميدسترسي مدیر داشته باشد 

 Shared Contactsدر بخش  را به اشتراک بگذارید که بقیه ي کاربران هاباید آني تان را دیگران هم ببینند هاخواهید فهرست تماسمياگر 

 را ببینند. هاآن

و در ي تهاي تان را دسته )گروه( بندي کنید )مثلا کاري، خانوادگي، دوستان و ... ( و همچنین گروه بنديهاتوانید متناسب با نیاز، تماسميشما 

 جاد نمایید.ایتو

ترسي ن بانک اطلاعاتي دسایيهاشود به دادهميتوانید از هر کامپیوتري که داخل شبکه ي محلي تان قرار دارد و به بانک اطلاعاتي تان متصل ميشما 

 داشته باشید.

 توانید آن را از گروهي به گروه دیگر منتقل کنید.ميپس از انتساب یک رکورد به گروه )دسته( خاص 

که محتویات آن در خارج از برنامه هم قابل مشاهده است  XMLي خود پشتیبان بگیرید. یکي به صورت فایل هاد از تماستوانیميشما به دو روش 

 .COBو دیگري به صورت محافظت و رمز نگاري شده با پسوند 

 توانید انتخاب کنید که چه رکوردهایي در آن ذخیره شوند.ميگیري به هنگام پشتیبان

دهد که به صورت قابل حمل و روي حافظه ي فلاش آن را استفاده کنید. بدین ترتیب که ميافزار به شما امکان سازي نرمپیادهاین روش طراحي و 

 اشد.ب برنامه و فایل اکسس آن را با خود همراه داشته باشید تا هر جا خواستید اجرا نمایید. فقط باید دات نت فریم ورک در کامپیوتر مقصد نصب

وند. طبق همین طرح شما ذخیره ش هاانتخاب کنید که رکوردیي را هانید از طرح )شماتیک( براي پشتیبان گیري استفاده نمایید و فیلدتواميشما 

اربري توانند فقط توسط کمي هان طرحایمیل در آن ذخیره شود.ایمثلا ممکن است یک پشتیان بخواهید بگیرید که فقط نام و نام خانوادگي و آدرس

 جاد کرده و همچنین کاربر )یا کاربران( مدیر ویرایش یا حذف شوند.ایه آن راک

ربري همان ن کار باید با نام کاای شود بهتر است که یک پشتیبان کامل از رکوردهاي آن کاربر بگیرید و برايميزماني که یک کاربر از سیستم حذف 

توانند در هر کاربر موجود یا کاربر جدید دیگري بازیابي شوند. به شرطي که نام کاربري و مين رکوردها این حالتایکاربر وارد سیستم شوید. در

 گذرواژه ي کاربر اصلي را بدانیم.

 ن برنامهایندهاییهانگارشیي برای هاایده

قابل حمل )فلش( در حال اجرا است یا نه. اگر شما از  ا از حافظهیآ طوري طراحي کنم که تشخیص بدهد ادر نظر دارم تا برنامه ر: قابليت انتقال

د ي رو کامپیوتر مقصهان برنامه حافظه فلش شما را از سرایت و انتقال ویروسای حالت اتوران براي اجراي برنامه استفاده کنید جالب خواهد بود که

 محافظت نماید.

ن امکان ای ندهایآ کند که به صورت متن ساده قابل مشاهده است. درميو ... را ذخیره  ن برنامه صرفا قرارهاای در حال حاضر: هایاد آوری رویداد

 .ظیم استخواهد بود که زمان مشخصي پیش از فرا رسیدن آن قرار ملاقات به کاربر اطلاع بدهد. زمان اطلاع دادن براي هر مورد قرار ملاقات قابل تن
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ن برنامه دقیقا از حالت گرافیکي سیستم شما در زمان اجرا اقتباس ایو ظاهر هادر حال حاضر فرمحالت گرافيکي ویندوز ویستا )ویندوز سون(: 

توان یک ویرایشگر قالب )تم یا اسکین( به برنامه اضافه کرد که هر کاربر بتواند حالت ظاهري را مطابق سلیقه ي خودش طراحي و ذخیره ميشود. مي

 نماید.

کند ولي در نگارش بعدي امکان پشتیباني از چند زبان و همچنین ميدر حال حاضر برنامه فقط از یک زبان پشتیباني  پشتيباني از چند زبان:

 ن که شما زبان مورد نظر تان را اضافه نمایید خواهد بود.ایامکان

ل آن را مستقیم تغییر دهید و باید از داخ توانیدميگیرید نميپشتیبان  هادر حال حاضر که از دادهگيری به صورت بانک اطلاعاتي: پشتيبان

کلیک خواهد بود که مستقیما و با دابل ن امکانای محیط برنامه فایل را باز کنید و نام کاربري و گذرواژه را وارد نمایید تا فایل باز شود. در نگارش بعدي

 دسترسي پیدا کنید. هاروي فایل آن را باز کنید و پس از وارد کردن نام کاربري و گذرواژه به داده

ویندوز است. نگارش  Address Bookدارد که بیشتر شبیه برنامه ي  هابرانمه در حال حاضر یک فرم ساده براي تماس ی جدید:هاافزودن تماس

 بعدي امکانات بهتري را خواهد داشت.

ه ن را خواهد داشت کاین برنامه امکانای کنندميبا دستکاري رجیستري ویندوز سیستم را آلوده  هااز آن جا که اغلب ویروس محافظت از سيستم:

 از سیستم شما محافظت نماید.

ن کنند خواهد داشت. همچنیميي شان در  شبکه استفاده هابرنامه امکان ارسال پیغام به کاربران دیگري که آن را بر روي کامپیوتر ارسال پيغام:

 ي کوچک به طور مستقیم بین کاربران خواهد بود.هاارسال فایلامکان 

ي بعدي امکان قالب بندي و هاگیرد. در نگارشميدر نگارش فعلي عملیات چاپ به صورت ابتدایي و با امکانات کم صورت  امکانات بهتر چاپ:

 ي متنوع تر چاپ فراهم خواهد شد.هاانتخاب


